Назначение

.

Настоящая справочная система посвящена обработке данных гидроакустического программно-технического комплекса (системы) «NetCorIP» по количественной оценке водных биомасс гидроакустическим методом в отложенном времени.

This help file was created with the free trial version of HelpScribble.


Немного теории

Гидроакустический метод оценки водных биомасс представляет собой комплексный и многостадийный процесс, основывающийся на фундаментальных физических знаниях о распространении и рассеянии ультразвука в воде, теории эхолокации, теории эксперимента и измерений, современных достижениях радиотехники, гидроакустической и электронно-вычислительной техники, прикладной математике и математической статистике, биологии и рыбохозяйственной науке. Количественная оценка гидробионтов, возможно, является самым важным применением гидроакустики в рыбохозяйственных научных исследованиях. В настоящее время в России использование гидроакустики в целях количественного изучения водных биоресурсов ведется в основном на морях и с использованием зарубежного оборудования и методик. На внутренних водоемах, включая прибрежные районы морей, исследования практически ограничены качественным описанием динамики распределения наблюдаемого с помощью гидроакустики ресурса или промысловой разведкой. Для России характерно обилие мелководных водоемов и водотоков с ценным рыбным населением, где вертикальная эхолокация рыб затруднена или невозможна. Кроме того, в вертикальном методе совершенно игнорируется рыба в приповерхностном слое.

Одним из критических допущений вертикального метода является стационарность восстанавливаемого поля плотности рыбных скоплений на обследованной акватории. Под стационарностью здесь понимается неизменность во времени статистических характеристик восстанавливаемого поля плотности рыбных скоплений на обследуемой акватории, по крайней мере, за время проведения съемки. Парадигма стационарности поля плотности совершенно неприемлема для количественной оценки проходных рыб, здесь задача количественной оценки решается через регистрацию параметров потока проходящих через наблюдаемое сечение реки рыб.

Исходя из изложенных выше общих соображений, в системе "NetCorIP" реализован подход с использованием сети пространственно разнесенных высокочастотных гидроакустических эхолотов (модули "slave") с многоэлементными антеннами, передающих по радиоканалу в нелицензируемом диапазоне радиочастот информацию о подводной обстановке в виде цифрового представления огибающей эхосигнала на береговую контрольно-измерительную компьютеризированную станцию (модуль "master"). Набор модулей "slave" образует неподвижную зону регистрации в выбранном для наблюдения сечении реки, рыба, в своем естественном движении, пересекает эту зону и происходит гидроакустическая регистрация проходящей рыбы. Общая схема использования комплекса "NetCorIP" представлена на рисунках 1, 2 и 3.

Рисунок 1. Общая схема использования комплекса «NetCorIP»

Рисунок 2. Схема расположения одной станции в сечении А-А. Вид сбоку

Рисунок 3. Схема определения направления движения цели в градациях вверх-вниз по течению по зарегистрированной трассе в зоне регистрации

(в допущении близкого к горизонтальному движению рыбы)

Гидроакустический программно-технический комплекс "NetCor" для передачи цифровых данных с сети модулей "slave" на модуль "master" береговой контрольно-измерительной станции использует беспроводную технологию Nanonet, разработанную фирмой Nanotron Technologies Gmbh (Германия). Ниже приведен список основных особенностей данной технологии:

- для передачи символов данных (бит) используются электромагнитные сигналы с плавно изменяющейся частотой (CSS-модуляция, Chirp Spread Spectrum). При этом для передачи двоичного символа может использоваться сигнал с увеличивающейся частотой, сигнал с уменьшающейся частотой и/или отсутствие сигнала. Также стандарт предусматривает возможность кодирования символов в четверичной (а не двоичной) системе счисления - в этом случае для кодирования нуля, единицы, двойки и тройки используется отсутствие сигнала, сигнал с увеличивающейся частотой, сигнал с уменьшающейся частотой и смешанный сигнал, соответственно;

- несущая частота составляет 2.4 ГГц, ширина спектра сигнала - 80 МГц;

- передача одного символа (то есть одного бита информации для случая двоичной системы счисления и двух бит для случая четверичной) длится 1 мкс, таким образом, предельная скорость передачи составляет 1 Мбит/с для двоичной и 2 Мбит/с для четверичной систем счисления, соответственно, для адресации узлов сети используются 6-байтовые числа, которые могут назначаться как централизованно, так и разработчиком приложений этой технологии.

При проектировании беспроводных сетей, по сравнению с сетями проводными, более остро стоит проблема управления доступом к среде передачи. В выбранной технологии существуют следующие решения:

a) Доступ с разделением по времени (TDMA, Time Division Multiple Access). При использовании этого способа узлы сети работают на передачу только в отведенное им время, так что коллизии (наложение сигналов разных узлов) исключены. Для осуществления данного алгоритма все узлы оснащены часами и предусмотрены специальные синхропакеты.

b) Доступ с обнаружением несущей (CSMA, Carrier Sensing Multiple Access). В этом случае узел имеет право работать на передачу только тогда, когда он не "слышит" никаких сигналов от других узлов. Определение занятости среды может быть основано либо на текущем значении уровня сигнала, либо на факте обнаружения символов (битов) данных.

c) Доступ с обнаружением несущей и предотвращением коллизий (CSMA/CA, Carrier Sensing Multiple Access/Collision Avoidance). Это более сложный вариант предыдущего способа. Перед тем, как начать передачу (при условии, что среда свободна), узел посылает получателю короткий запрос на передачу. Если получатель свободен от приема данных, то он отвечает коротким разрешением на передачу. Все остальные узлы, которые зарегистрировали данный обмен пакетами, обязаны не транслировать сигнал в среду в течение времени, рассчитанного по специальному алгоритму.

Для выбора способа кодирования бита (двоичный или четверичный) в комплексе "NetCor" исходили из следующих допущений и параметров:

- объем данных с одного модуля "slave" за один цикл сканирования одним элементом многоэлементной антенны - 512 двухбайтных слов (короткое знаковое целое число), что при частоте аналого-цифрового преобразования 18.2 КГц соответствует дальности регистрации 20 м;

- при использовании шестиэлементной гидроакустической антенны объем данных составит 6 килобайт или 48 килобит;

- частота следования циклов сканирования с одного модуля "slave" - 4 Гц;

- поток данных с одного модуля "slave" с шестиэлементной антенной за один цикл сканирования составит 192 килобита в секунду.

В результате имеем, что в случае двоичного кодирования бита заявленная предельная скорость передачи данных 1 Мбит/с обеспечит работу 5 модулей "slave" с шестиэлементной антенной, а в случае четверичного кодирования бита заявленная предельная скорость передачи данных 2 Мбит/с обеспечит работу 10 модулей "slave" с шестиэлементной антенной.

Для выбора управлением доступом к среде передачи в комплексе "NetCor" исходили из следующих допущений и параметров:

- для надежной идентификации контрастной движущейся цели число регистраций за время её нахождения в зоне регистрации должно быть больше двух раз;

- известно, что скорость движения рыбы не превосходит значения соотношения длины рыбы ко времени, в нашем случае средняя длина рыб оценивается величиной 0,7 м, соответственно скорость движения принимается равной 0,7 м/с;

- ширина характеристики направленности (на уровне -3 ДБ) для выбранной шестиэлементной антенны в горизонтальной плоскости составляет 80о, принимаем это значение как ширину зоны регистрации в горизонтальной плоскости;

Несложные тригонометрические расчеты показывают, что рыба, движущаяся со скоростью 0,7 м/с на расстоянии 0,5 м от антенны будет находиться в зоне регистрации не менее 1 секунды, то есть будет зарегистрирована не менее четырех раз, при частоте следования циклов сканирования с одного модуля "slave" 4 Гц. При тех же условиях, но на расстоянии 0,3 м одиночная рыба будет зарегистрирована не менее 2 раз.

В комплексе "NetCor" используется доступ к среде с обнаружением несущей (CSMA, Carrier Sensing Multiple Access), сигнал занятости среды задается модулем "Master" береговой контрольно-измерительной станции. Выбранная и реализованная схема кодирования и доступа к среде обеспечивает параллельный сбор цифровой информации с 10 модулей "slave" с шестиэлементными антеннами , установленных на плавучих платформах. Число модулей "slave" определяется при локализации (адаптации) комплекса под конкретные условия исследования и пожелания заказчика.

Основной трудностью регистрации групповых объектов пространственно разнесенными измерительными системами является неопределенность принадлежности полученной регистрации тем или иным регистратором тому или иному объекту регистрации. Для наиболее близкого, к условиям поставленной задачи гидроакустической регистрации проходящих рыб, случая восстановления совокупности траекторий движущихся точек по зашумленным следам при дискретной по времени регистрации, сказанное иллюстрируется графиками на рисунке 4.

Рисунок 4. К возможности потери и появлению ложных целей при дискретной (по времени) регистрации

При движении одной точки, оставляющей зашумленные следы, где зашумленность - ошибки измерений, то восстановление ее траектории не вызывает затруднения. Если движется группа точек, то число вариантов объединения регистраций, относящихся к одному объекту, растет экспоненциально с увеличением числа циклов наблюдения и числа регистраторов, что делает задачу корректной интерпретации числа регистраций в число прошедших объектов сложной. Неразличимость совокупностей для двух регистраторов и двух точек может быть проиллюстрирована рисунком 5

Рисунок 5. К неразрешимости двух целей двумя регистраторами

Применительно к варианту расположения гидроакустических регистраторов в линию, возможная неразрешимость групповых целей хорошо иллюстрируется ситуацией на рисунке 6. Суммарный сигналы от двух рыбы (1 и 3), находящихся у края зон регистраций антенн 1 и 2 будет неотличим от эхосигнала от рыбы 2, находящейся в зоне совместной регистрации.

Рисунок 6. К возможной неразрешимости групповых целей

Для установки модуля "slave" в комплексе "NetCor" разработана и изготовлена полая плавучая платформа из стеклопластика грузоподъемностью 30 кг с габаритами 1370х1050х270 мм, со сквозным колодцем для пропуска гидроакустической антенны на поворотно-выдвижном координатном штативе, с самоотливным кокпитом для аккумулятора.

На рисунке 7 представлена фотография комплекса "NetCor" с тремя модулями "Slave" во время работ на реке Онега Архангельской области.

1. Состояние акустического поля в упругой водной среде описывается зависимостью давления от координат места и времени в виде дифференциального уравнения в частных производных.

где:

p - давление звука в точке x,y,z в момент времени t ;

с - скорость звука.

Использование приведенного строгого уравнения и расчеты по нему затруднены недостаточностью информации о фактических параметрах среды. На практике, по аналогии с геометрической оптикой, для описания состояния поля в точках пространства и времени, используются методы лучевой акустики, подразумевающие игнорирование информации о фазе акустической волны, значительное превышение размеров рассеивателей над длиной акустической волны и отсутствие значимых изменений характеристик среды на длине волны.

2. Гидроакустический метод оценки водных биомасс является вариантом обратной задачи рассеяния. Общая теория обратной задачи рассеяния описывает эхосигнал исключительно как совместный результат отражательной способности цели, её нахождения в пространстве и потерь звука на распространение. Имея информацию только в виде принятой звуковой волны с известной интенсивностью (давлением), эта задача не имеет однозначного решения, так как, одна и та же форма эхосигнала может быть образована разными составами рассеивателей. Определение плотности зарегистрированных объектов, как решение обратной задачи рассеяния в гидроакустическом методе количественной оценки водных биомасс, всегда требует дополнительной информации о зарегистрированных рассеивателях.

3. Для учета потерь интенсивности звуковой волны при её распространении применяется модель сферической волны с учетом фактора затухания. На относительно небольших дистанциях, на которых происходит гидроакустическая оценка водных биомасс, и при недостаточности знаний о специфических условиях распространения звука в конкретных обстоятельствах, считается вполне допустимым учет потерь на распространение и затухание ультразвука в воде для сферического фронта распространяющейся волны по формуле: ПР=20LgR+aR, где: ПР - потери интенсивности распространяющейся звуковой волны, R - пройденное волной расстояние, м, a - коэффициент затухания, дБ/м. В промысловой гидроакустике потери интенсивности эхосигнала от одиночных целей определяются по формуле: ПР=40LgR+aR, а для групповых целей по формуле: ПР=40LgR+aR.

4. Селекция эхосигналов от одиночных и групповых целей производится по критерию соответствия длительности эхосигнала и длительности генерируемой посылки эхолота.

5. Распределение вероятностей амплитуд зарегистрированных одиночных эхосигналов есть результат свертки вероятностей:

,

где: - плотность распределения вероятностей амплитуд зарегистрированных одиночных сигналов; [image] - плотность распределение вероятностей регистрации цели под определенным углом обнаружения; [image] - искомая плотность распределения вероятностей отражательной способности одиночных целей. В численном решении приведенного выражения используется кусочно-линейная аппроксимация.

6. Зависимость энергии эхосигнала от плотности рассеивателей линейна при условии случайного распределения рассеивателей в озвученном объеме:

где: E - средняя энергия эхосигнала; n - - число рассеивателей в озвученном объеме; [image] - средняя энергия эхосигнала от единичного рассеивателя.

Линейная зависимость применима только при выполнении условий релеевского рассеяния в озвученном объеме, при котором функция распределения вероятностей значений интенсивности определена выражением : , где I - интенсивность эхосигнала.

7. Напряжение на клеммах гидроакустического преобразователя прямо пропорционально звуковому давлению падающей волны. Энергия эхосигнала прямо пропорциональна интенсивности эхосигнала, или квадрату его среднеквадратичного давления, или квадрату напряжения на клеммах антенны, мерой энергии эхосигнала служит интеграл вида: {

bmct pic16.png}

Физический смысл пределов интегрирования - верхний и нижний границы слоя интегрирования, причем нижняя граница слоя может быть переменной от посылки к посылки эхолота и определяется положением дна. На практике, интеграл накапливается за ряд циклов прием - передача (посылок эхолота) и его среднее значение определяется формулой:

, где где: E - интеграл эхосигнала; N - число посылок эхолота.

Тогда для плотности рассеивателей, образующих интегрируемый эхосигнал, справедливо следующее выражение, известное как уравнение интегрирования:

где:

- средняя плотность рассеивателей в интервале накопления;

C - калибровочная постоянная, зависящая от чувствительности акустического преобразователя и сквозного усиления аналоговых трактов эхолота и интегратора;

- ошибка компенсации потерь интенсивности на распространение и затухание звука при его распространении;

- среднее накопление интеграла;

- среднее значение сечения обратного рассеяния объектов, образующих интегрируемый сигнал;

- интегральный фактор направленности - идеализированнон представление характеристики направленности в виде телесного угла, в пределах которого, интегрирование даст тот же результат, что и в пределах реальной пространственной характеристики направленности при условии случайного распредеелния рассеивателей в озвученном объеме:

8. Непосредственным результатом количественной оценки плотности водных биомасс гидроакустическим методом являются пространственно распределенные относительные значения плотности [image] оцениваемых гидробионтов.

9. Абсолютная численность (биомасса) может быть восстановлена вычислением интеграла:

где: Q - абсолютное значение численности или биомассы в экземплярах или килограммах;

p(x,y) - функция, определяющая значение плотности в декартовых координатах. На практике выполняется численное интегрирование через использование интерполированных в узлы регулярной двухмерной координатной решетки пространственно распределенных значений плотности:

,

где: Q - абсолютное значение численности или биомассы;

p(x,y) - значение плотности в координатах ;

a1,a2 - значения интервалов между узлами решетки;

p1,p2 - целочисленные индексы, нумерация которых зависит от координат начальной точки.

10. При использовании сканирующих гидроакустических приборов дистанционная размерная классификация гидробионтов осуществляется путем излучения акустической энергии широким лучом (пучком) в плоскости, перпендикулярной направлению движения судна, прием производится узким лучом (пучком), сканирующим в пределах указанного широкого луча. При этом, выделение максимального уровня амплитуды эхосигналов от отдельно разрешаемых гидробионтов производится путем сравнения последовательных выборок уровней эхосигналов в каждом такте электронного поперечного сканирования за n циклов лоцирования от начала и до окончания эхоконтактов с объектами при движении судна. Функционально измеритель, использующий секторный сканирующий гидролокатор (эхолот) по сути, является третьей реализацией прямого метода дистанционного определения размерного состава гидробионтов, так как он обеспечивает возможность измерения уровней эхосигналов от цели, находящейся на оси диаграммы направленности приемной антенны. Анализ известных технических решений в данной области техники позволяет сделать вывод о том, что в настоящее время этот метод является единственно возможным для определения силы цели рыб "in situ" (и соответственно размерного состава) в условиях мелководий с глубинами менее 5м.

Реализация этого метода осуществляется следующим образом. При движении судна пространство водной акватории последовательно озвучивается широким лучом (пучком) в поперечной плоскости относительно направления перемещения. Узкая приемная характеристика направленности с высокой скоростью (до нескольких кГц или более) электронным способом сканирует в пределах указанного широкого луча (пучка). В каждом такте сканирования запоминаются амплитудные значения принимаемых эхосигналов от отдельных гидробионтов. В результате за один цикл лоцирования может быть получено m максимальных выборок эхосигналов от m отдельно разрешаемых объектов. В следующем цикле лоцирования выборки амплитуд эхосигналов, от обнаруженных объектов, соответствующим образом сравниваются с предыдущими значениями, и в блоке памяти остаются лишь максимальные значения амплитуд из m сравниваемых. Далее циклы повторяются. Таким образом, в процессе движения судна (от цикла к циклу лоцирования и от такта к такту сканирования) осуществляется отбор наибольших значений эхосигналов от отдельно разрешаемых рыб, попавших в зону зондирования широкого луча (пучка) . Запомненные амплитуды пересчитываются в значения силы цели рыб TS , относительно амплитуд эхосигналов от образцовой сферы, полученных при градуировке аппаратуры. По полученным значениям TS рыб рассчитываются размеры рыб с использованием известных эмпирических формул.

Количество учитываемых циклов лоцирования и тактов сканирования при анализе отсчетов от данной цели определяется продолжительностью эхоконтактов с нею.

Преимущество описанного способа, по сравнению с ранее известными, заключается в том, что существенно более широкая зона одновременного обзора позволяет значительно быстрее набрать необходимую статистику эхосигналов от отдельных объектов различных размеров для определения репрезентативного размерного распределения (ряда) рыб в скоплении. Более высокая скорость набора статистически значимых результатов измерений способствует повышению точности оценки размерного состава обнаруженных рыбных скоплений для ситуаций с ограниченными возможностями по продолжительности проведения съемок. В результате непрерывного набора материалов за определенные промежутки времени и пространства, возможно использование полученных данных о размерном составе скоплений для дифференциации скоплений по видам.

Направление, в котором обнаруживается максимальный сигнал от данной цели, находится из последовательности отсчетов огибающей, полученной за ряд циклов лоцирования и тактов сканирования. Выделение отсчетов, принадлежащих отдельным целям, осуществляется автоматически с записью амплитуды, времени регистрации и расстояния до цели в файл памяти компьютера для последующего анализа размерного распределения рыб в водоеме (или его участке). В качестве критериев для селекции сигналов используются амплитудно-временные характеристики полученных серий отсчетов. Уровень принимаемого сигнала от рыбы зависит от характеристик рассеяния рыбы, ее местоположения в акустическом луче и электро-акустических параметров аппаратуры. Если сигналы усиливаются с ВАРУ по закону 40 lg r + 2 ar, где r - расстояние до цели, a - коэффициент затухания звука в воде, то уровень амплитуды принимаемого сигнала:

(1), где где U - уровень амплитуды эхосигнала, Gизл , Gпр , Gр - соответственно функции направленности излучения, приема и рассеяния рыбы по звуковому давлению, [image] - акустическое сечение обратного рассеяния одиночной рыбы, находящейся на акустической оси антенны при облучении со стороны спины, С - электроакустическая постоянная аппаратуры, определяемая в результате градуировки аппаратуры с использованием образцовой сферы. В процессе анализа поступающей информации каждому зарегистрированному отдельному объекту присваивается максимальный отсчет амплитуды Uijk , где I - номер цикла лоцирования, j - номер положения сканирующего луча в пространстве, k - номер такта сканирования и глубина. Для максимальных отсчетов амплитуды можно принять: Gизл = Gпр = 1 , т.е. объект локации находится на оси характеристики направленности антенны, следовательно, формулу (1) можно переписать в виде: (2), откуда [image] . Под Gpj понимается усредненная по всем азимутальным углам функция направленности рассеяния рыбы, зависящая от угла облучения. В данном случае зависимость функции направленности от угла облучения указывается индексом j , определяющим положение сканирующего луча в обследованном секторе. Значения Gpj могут быть найдены на основе сопоставлений усредненных уровней эхосигналов для соответствующих направлений сканирующего луча в генеральной совокупности отсчетов.

Точность измерения максимальных уровней сигнала зависит от многих факторов, в том числе, от скорости судна Vс , частоты следования импульсов зондирования f , скорости сканирования приемного луча w и частоты преобразования сигнала в цифровом виде F. В метрологических измерениях принято считать, что для достоверной оценки энергетической характеристики эхосигнала достаточно иметь порядка 10 отсчетов исследуемых импульсов. Учитывая, что длительность импульса от одиночной цели соизмерима с длительностью импульса зондирования t , требуемая частота преобразования F1.

F1 = 10/ r (4) .

Формула (4) справедлива для традиционного однолучевого эхолота. В случае использования сканирующей системы (эхолота или гидролокатора) частота преобразования должна быть увеличена в n раз:

F1 = 10 n / r , (5)

где n - число отсчетов в одном такте сканирования.

Если сканирование производится без наложения зон действия приемной антенны для предыдущего и последующих отсчетов (без перекрытия), то

n = Qизл / ?Qпр , (6)

где Qизл и ?Qпр - ширина характеристики направленности антенн в плоскости, перпендикулярной продольной оси судна, соответственно в режиме излучения и приема на уровне - 3 дБ по давлению.

В случае использования наложения (перекрытия) зон действия приемной антенны для предыдущего и последующих отсчетов, число отсчетов в одном такте сканирования составит

n = Qизл / Q'пр (1- Kп) , (7)

где Kп - степень перекрытия зон, 0 < Kп < 1.

Для уверенной селекции сигналов необходимо получить отклик от отдельной цели на протяжении как минимум 5 циклов лоцирования. Чтобы это требование удовлетворялось, должно выполняться условие:

2 r tg (Q/2) = 5 Vc / f ,

где r - дистанция до цели, м;

Q - ширина характеристики направленности в плоскости параллельной продольной оси судна, на уровне - 3 дБ по давлению, градус;

Vc - скорость судна, м/с;

f - частота следования импульсов зондирования, 1/с.

В плоскости сканирования аналогичное условие выполняется, если

2 tg Qп /2 = 5 w/F , (9)

где w - круговая скорость сканирования, рад/с.

При подстановке значений электроакустических параметров сканирующего гидролокатора "PanCor" и однолучевого научного эхолота комплекса "Аскор" в вышеприведенные формулы можно судить о том, что производительность сканирующих систем в 7 - 10 раз выше. Кроме того, возможность размерной классификации рыб в мелководных водоемах, с глубинами менее 5 м., возможно только с использованием сканирующего гидролокатора как в режиме горизонтального, так вертикального сканирований.

Видовое распознавание основывается на связи между формой эхосигнала и конструкцией плавательного пузыря рыбы.

Двукамерный пузырь (карповые) дает двухмодальный эхосигнал, асимметричный пузырь (окуневые) дает асимметричный сигнал, симметричный пузырь (сиговые) дает симметричный сигнал. Для восстановления формы сигнала используется повышенная частота выборки АЦП.


Контакты

185034, гор. Петрозаводск, пер. 4-й Родниковый, д. 17

Директор - к.т.н. Дёгтев Андрей Игоревич

+7 921 4565745

rickoshet_PHA@mail.ru

© ® ООО "ПромГидроакустика", 2005 - 2018


Состав ПО

Программное обеспечение отложенного времени состоит из исполняемого модуля Process.exe, библиотеки PHA64.dll, файла встроенной помощи Process.chm.


Установка ПО

Программное обеспечение поставляется в виде установочной программы Setup.exe на диске CD. Программа установки создает каталог NetCorIP на диске С, в каталог NetCorIP копирутся файлы Process.exe и PHA64.dll, и создаются каталоги EchoData и Help. В каталог Help копируются файлы встроенной справочной системы, в каталог EchoData пользователь переносит файлы данных для обработки.

На CD диске находится также каталог NetCorIP со всеми указанными выше файлами, можно просто скопировать этот каталог на диск C.


Удаление ПО

Удаление программного обеспечения осуществляется средствами ОС Windows или программой uninstall.exe.


Файл данных

В файл данных системы «NetCorIP» записывается цифровое представление огибающей эхосигнала и номера работающих модулей. Имя файла данных - "ddmmyy_hhmm.rnd", где ddmmyy - текущая системная дата открытия файла, hhmm - текущее системное время. В файл данных записываются данные со всех модулей "Slave", работавших в момент записи.

Файл данных не может быть изменен пользователем с использованием средств настоящей программы.

Структура файла:

struct

{

unsigned char //физический номер модуля "Slave" (адрес)

unsigned char //не используется

unsigned char //частота выборки АЦП (базовый диапазон)

unsigned char //длительность имульса

unsigned char //мощность генератора

unsigned char * //порядок работы элементов антенны

unsigned char //не используется

unsigned char //берег

}

struct

{

unsigned char //логический номер модуля "Slave"

unsigned char //физический номер модуля "Slave" (адрес)

unsigned char //год

unsigned char //месяц

unsigned char //число

unsigned char //час

unsigned char //минута

unsigned char //секунда

unsigned char * //целочисленный массив отсчетов АЦП

}


Файл результатов

Тестовый файл с разделением полей табуляцией с расширением ".txt", с именем, совпадающим с именем файла данных, к имени файла результатов добавляется физический номер модуля.

В файл выводятся результаты обработки страницы, выведенные в таблицы на панели результатов.

Файл результатов записывается в тот же каталог, где и был открыт файл данных.

Результаты за страницу 1

Число единичных целей 25073

Среднее значение TS, дБ -31,8

Среднее значение SV, дБ -36,4

Среднее значение SA, дБ -15,8

Численность за страницу, экз. 38

Результаты по кадрам

№ кадра Время окончания SV, дБ Численность, экз.

1 1:00:59 -58,5 0

2 1:01:59 -50,7 1

3 1:02:59 -45,7 4

4 1:03:59 -46,9 3

5 1:04:59 -48,1 3

6 1:05:59 -43 8

7 1:06:59 -45,3 5

8 1:07:59 -48,8 2

9 1:08:59 -45,2 5

10 1:09:59 -46,7 4

11 1:10:43 -48,9 2

Направление

№ цели Время TS, дБ Качество Направление

1 1:02:08 -28,2 0,45 0

2 1:02:14 -28,9 -0,76 1

3 1:02:34 -28,2 -0,16 0

4 1:02:47 -28,4 -0,44 0

5 1:03:06 -29,1 -0,45 0

6 1:03:10 -29,2 0,79 -1

7 1:03:28 -29,2 0,14 0

8 1:03:55 -29 -0,03 0

9 1:04:02 -28,1 -0,49 0

10 1:04:07 -29,2 0,27 0

11 1:04:19 -29,5 -0,35 0

12 1:04:58 -28,2 -0,82 1

13 1:05:06 -29,5 -0,6 1

14 1:05:14 -29,4 -0,62 1

15 1:05:29 -28,1 -0,05 0

16 1:05:41 -29,3 -0,35 0

17 1:05:51 -28,4 -0,22 0

18 1:05:49 -29,9 -0,52 1

19 1:05:53 -29,2 -0,01 0

20 1:06:09 -28,3 -0,24 0

21 1:06:17 -28,2 -0,63 1

22 1:06:46 -29,2 -0,01 0

23 1:06:51 -28,5 -0,87 1

24 1:06:51 -28,5 -0,52 1

25 1:07:38 -29,3 0,27 0

26 1:07:57 -28,6 0,36 0

27 1:08:06 -29,3 0,22 0

28 1:08:13 -28,7 0,7 -1

29 1:08:15 -28,3 0,25 0

30 1:08:26 -28,1 -0,37 0

31 1:09:03 -28,4 -0,36 0

32 1:09:07 -28,8 -0,3 0

33 1:09:22 -29 0,55 -1

34 1:09:41 -28,2 -0,21 0

35 1:10:01 -28,2 -0,66 1

36 1:10:17 -28,1 -0,57 1


Файл конфигурации

Имя и путь двоичного файла - C:\NetCorIP\ProcConfig.cfg

В файле сохраняется структура параметров работы программы:

struct

{

int //солёность

int //температура

double //коэффициент затухания

int //порог регистрации

int //шум АЦП

bool //отбражать фильтрованную эхограмму?

bool //ночной/дневной фон эхограммы?

bool //цветная/чёрно-белая эхограмма?

int //верхняя граница обработки

double //интегральный фактор направленности антенны

int //временной лаг кадров

int //максимальная сила цели

int //минимальная сила цели

int //размер аппертуры цифровой фильтрации

int //минимальная длина следы одиночной рыбы

double * //массив индивидуальных электро-акустических постоянных (по числу модулей "Slave")

double //коэффициент логарифматора

double * //массив индивидуальныхсквозных атенюаторов (по числу модулей "Slave")

bool //производить определение направления движения?

double //коэффициент корреляции определения направления движения

double //ширина ворот определения одиночной цели

}


Пользовательский интерфейс

Пользовательский интерфейс программы состоит из:

- панели главного меню (вверху окна);

- панели цветности (крайнее левое);

- панели дистанции (крайнее правое);

- панели эхограммы (ниже панели главного меню);

- панели результатов (ниже панели эхограммы);

- панели состояния (крайнее нижнее).


Главное меню

Панелm состоит из следeющих кнопок:

- "Помощь F1";

- "Настройка F2", недоступна до открытия файла данных;

- "Файл F3";

- "Предыдущая F4", недоступна до открытия файла данных;

- "Следующая F5", недоступна до открытия файла данных;

- "Результаты F6", недоступна до открытия файла данных;

- "Запись F7", недоступна до открытия файла данных и до нажатия кнопки "Результаты F6";

- "Модуль F8", недоступна до открытия файла данных;

- "О программе F9";

- "Выход F10".


Панель цветности

Поле отображает условное соответствие цвета и интенсивности эхосигнала, является элементом управления обработкой:

- левый "клик" мыши изменяет порог регистрации на значение у курсора, перестраивается панель цветности, панель эхограммы, изменение порога влияет на результаты;

- при движении курсора по панели в районе значения -18, форма курсора меняется с указателя на "палец", если сделать левый "клик" мышью при форме "палец" - значение порога регистрации вернется к рекомендованному значению -50 дБ;

- правый "клик" мыши вызывает простое контекстное меню для изменения цветного изображения эхограммы на черно-белое и обратно и изменения фона эхограммы с белого на черный и обратно.


Панель дистанции

Поле представляет собой шкалу дистанции в метрах, является элементом управления обработкой:

- при движении курсора по полю с нажатой левой кнопкой мыши, устанавливаетмя верхняя граница слоя обработки;

- при движении курсора по полю с нажатой правой кнопкой мыши, устанавливаетмя нижняя граница слоя обработки.

Верхняя граница слоя не установится выше параметра - верхней границы, установленного в настройках.

Нижняя граница не установится выше верхней границы слоя, при такой попытке появится сообщение:

Закройте его и повторите попытку установки слоя корректно.


Панель эхограммы

Поле отображает подводную обстановку в виде эхограммы в пределах страницы обработки. Вверху поля находятся метки времени, на эхограмме горизонтальными прерывистыми линиями указаны верхняя граница обработки и границы слоя.

При движении курсора по эхограмме в панели состояния индицируется положение курсора по дистанции и времени.

Панель является элементом управления обработкой, правый "клик" вызывает контекстное меню из трёх позиций:

- "Оригинал" - на панели изображается эхограмма, построенная по фактическим данным АЦП;

- "Фильтр" - на панели изображается эхограмма, построенная по фильтрованным (фильтр низких частот) данным АЦП.

- "Осциллограф" - вызывает (закрывает) окно осциллографа.

После нажатия кнопки "Результаты F6" происходит обработка страницы, ход обработки индицируется движением вертикальной прерывистой линии по эхограмме в пределах установленного слоя обработки.

После прохода линии по всей странице обновляется эхограмма - на ней остаются только те сигналы, которые будут учтены, страница разбивается на кадры, на ней отражается линия накопления (ломанная прерывистая линия из левого верхнего в нижний правый угол), на панели результатов появляются таблицы и графики.


Панель результатов

Поле отображает результаты обработки текущей страницы файла данных.

На графике "Результаты за страницу" отображаются гистрограммы распределения амплитут одиночных целей и восстановленное распределение силы цели методом Крейга-Форбса. Ниже графика приводится таблица сводных результатов.

В таблице "Результаты по кадрам" отображаются результаты определения численности по кадрам, данные из таблицы записываются в файл результатов.

В таблице "Направление" отображаются результаты определения направления движения рыбы в градациях вверх-вниз по течению: 1 вверх, -1 вниз, 0 не определено. Числа в столбце "Качество" равны коэффициенту корреляции Пирсона, при их абсолютном значении меньшим, чем коэффициент корреляции в настройках, направление считается неопределенным. Данные из таблицы записываются в файл результатов.


Панель состояния

В поля (слева-направо) панели выводятся следующие данные:

- имя фала данных;

- число модулей, работавших в системе, поле - элемент управления программой: левый "клик" мыши вызывает контекстное меню со списком работавших модулей - аналог кнопки "Модуль F8";

- логический номер модуля, поле - элемент управления программой: левый "клик" мыши вызывает контекстное меню со списком работавших модулей - аналог кнопки "Модуль F8";

- адрес модуля;

- число страниц обработки в текущем файле данных;

- текущая страница обработки, поле - элемент управления программой: левый "клик" мыши вызывает контекстное меню со списком доступных страниц, можно переключать страницы, по аналогии с кнопками "Предыдущая F4" и "Следущая F5";

- берег, на котором был установлен модуль;

- имя файла результатов (если открыт);

- время и дистанция точки положения курсора на панели эхограммы.


Запуск программы

Запустите программу Process.exe средствами ОС "Windows", появится окно приглашения:

В поле "Параметры системы" для выбора пользователя есть две радиокнопки: "Встроенные значения" и "Сохранённые значения". Кнопка "Сохранённые значения" доступна только, если в предыдущем сеансе пользователь изменил и сохранил параметры работы программы.

Если доступна только кнопка "Встроенные значения" пользователю достаточно сделать "клик" левой кнопки мыши для прехода к пользовательскому интерфейсу программы и началу работы.

Если доступны обе кнопки, пользователь должен выбрать набор параметров - встроенных или сохранённых и сделать "клик" левой кнопки мыши для прехода к пользовательскому интерфейсу программы и началу работы.

Выбор кнопки "Встроенные значения" приведет к работе программы с параметрами, установленными разработчиком.

Выбор кнопки "Сохранённые значения" приведет к работе программы с параметрами, изменёнными и сохраненными пользователем в файле конфигурации в предыдущем сеансе работы с программой.

Откроется окно пользовательского интефейса программы.


Параметры системы

Неизменяемые параметры.

Номер комплекса - записан в ПЗУ производителем.

Модуль - физический номер модуля, данные с которого обрабатываются.

Берег - берег реки, на котором бал установлен модуль "Slave" при работе системы. Берег, от которого смотрит гидроакустичеая антенна.

Интегральный фактор направленности - идеализированное представление характеристики направленности используемой гидроакустической антенны.

Длительность импульса - длительность зондирующего акустического импульса, использовавшегося при работе системы.

Максимальная дистанция - максимальная дистанция регистрации, использовавшеяся при работе системы.

Параметры среды.

Соленность воды, встроенное значение 0, макс. 35 промилле.

Температура воды, встроенное значение 0, макс. 30 град С.

Коэффициент затухания звука в воде, встроенное значение 0,0546 дБ/м.

Параметры системы.

Коэффициент сжатия, встроенное значение 40, измеряется изготовителем, не рекомендуется к самостоятельному изменению пользователем.

Системный аттенюатор, встроенное значение 34,7, измеряется изготовителем, не рекомендуется к самостоятельному изменению пользователем.

Электро-акустическая постоянная, встроенное значение 37,5, измеряется изготовителем, не рекомендуется к самостоятельному изменению пользователем.

Шум, встроенное значение 100, измеряется изготовителем, не рекомендуется к самостоятельному изменению пользователем.

Параметры обработки.

Верхняя граница, встроенное значение 1 м, мин. 1 м, значение более 2 м не рекомендуется.

Временной лаг, встроенное значение 1 минута, мин. 1 минута.

Минимальная TS, встроенное значение -38 дБ.

Максимальная TS, встроенное значение -28 дБ.

Апертура, встроенное значение 48 ед., устанавливается изготовителем, не рекомендуется к самостоятельному изменению пользователем.

Минимальная. длина следа, встроенное значение 4, мин. 2, значение более 6 не рекомендуется.

Коэффициент корреляции, встроенное значение 0,5, рекомендуемое значение от 0,3 до 0,7.

Критерий одиночной цели, встроенное значение 2, рекомендуемое значение от 1,2 до 2,4.

Определение направления, встроенное значение -Да.

Параметры изображения.

Порог регистрации, встроенное значение -50 дБ, мин. -50 дБ, значение более -42 дБ не рекомендуется.

Цветность, встроенное значение цветное, возможно использования черно-белого, на результаты не влияет.

Фон эхограммы, встроенное значение дневное (белое), возможно использования черного (ночного), на результаты не влияет.


Последовательность обработки

Откройте файл данных. На панели эхограммы появится изображение подводной обстановки (страница обработки), появятся панели цветности и дистанции, данные на панели состояния, станут доступными кнопки на панели меню. При необходимости установите слой на панели дистанции и значения параметров обработки вызовом окна настройки.

Запустите обработку страницы нажатием кнопки "Результаты F6" панели меню.

Сохраните результаты обработки страницы нажатием кнопки "Запись F7" панели меню в файл результатов.

Перейдите к следующей или предыдущей странице обработки и повторите описанную процедуру.

После обработки файла данных перейдите к другому фалу.

По окончанию работы закройте программу.


Введение

This help file was created with the free trial version of HelpScribble.


Отложенное время

Настоящая справочная система посвящена обработке данных гидроакустического программно-технического комплекса (системы) «NetCorIP» по количественной оценке водных биомасс гидроакустическим методом


Программное обеспечение

This help file was created with the free trial version of HelpScribble.


Модуль "Slave"

Модуль «Slave» состоит из программно-управляемого генератора-приемника, АЦП, радио приемного и передающего устройства стандарта NanoLoc, ненаправленной радиоантенны. Осуществляет гидроакустическое сканирование подводной обстановки с параметрами задаваемыми модулем «Master» и передачу данных в компьютер по радиоканалу через модуль «Master». На корпусе гравировкой и наклейкой указан физический номер модуля. Модуль подключен к ненаправленной (штыревой) радиоантенне.


Физический номер

Физический номер модуля "Slave"

Физический номер модуля «Slave» записан в ПЗУ модуля, состоит из двух байт: старший - серийный номер комплекса, младший - адрес модуля в сети, в пользовательском интерфейсе программы показывается только младший байт, как физический номер конкретного модуля «Slave». Не может быть изменен пользователем! Физический номер выгравирован на корпусе и дублирован наклейкой.

Каждый модуль «Slave» имеет два номера: физический (адрес в сети) и логический. Логический номер определяет последовательность работы модулей в сети и является, по сути, именем, назначаемым пользователем, каждому модулю «Slave» в конкретной реализации сети. Логический номер определяется пользователем.


Работа с программой

This help file was created with the free trial version of HelpScribble.


Помощь F1

Открывает встроенную справочную систему.


Настройка F2

Вызывает окно настройки параметров обработки. Доступно только при открытом файле данных.

Окно настроек состоит из четырёх вкладок:

- "Неизменяемые параметры";

- "Параметры среды";

- "Параметры системы";

- "Параметры обработки".


Файл F3

Открывает файл данных для обработки. По умолчанию файлы ищются в каталаге c:\NetCorIP\EchoData, но могут быть взяты и с любого другого носителя и каталога.

По открытию файла изменится содержание панели меню, панели эхограммы, панели дистанции, панели результатов и панели состояния.


Предыдущая F4

Предыдущая страница F4

Переключает эхограмму на одну страницу вперед. Становится недоступной на последней странице фала данных, число страниц и номер текщей страницы указывается на панели состояния.


Следующая F5

Следующая страница F5

Переключает эхограмму на одну страницу назад. Становится недоступной на первой странице фала данных, число страниц и номер текщей страницы указывается на панели состояния.


Результаты F6

Запускает процесс обработки текущей страницы, ход обработки сопрождается движением вертикальной прерывистой линии по эхограмме, вид эхограммы меняется вслед за движением линии.

В ходе обработки производится низкочастотная цифровая фильтрация эхосигнала, эхоинтегрирование, эхосчет, выделение следов движения рыб, расчет и вывод результатов в таблицы на панели результатов.


Запись F7

Записывает данные, отраженные в таблицах панели результатов за текущую страницу обработки в файл результатов.

После нажатия становится недоступной.

Становится доступной после открытия файла данных или смены страницы после нажатия кнопки "Результаты F6".


Модуль F8

Если в процессе работы системы использовалось несколько модулей "Slave", данные с них записываются в файл данных. По открытию файла данных, программа сообщает о числе работавших модулей в панели состояния. Если число работавших модулей более одного - кнопка "Модуль F8" становится доступна. Переключение обработки по использовавшимся модулям производится кнопкой "Модуль F8" или контектным меню из панели состояния.


О программе F9

Содержит информацию о программе и разработчике.


Выход F10

Закрывает программу.

Корректно закрываются файлы данных и результатов, если открыты.

Если пользователем были изменены параметры обработки, появляется приглашение об их сохранении в файле конфигурации:


Страница

Страница обработки

Основной элемент обработки. Файл данных разворачивается по страницам, файл результатов записывается по страницам. Горизонтальный размер страницы определяется разрешением используемого монитора. Страница разбита на кадры, горизонтальный размер кадра определяется пользователем в настройках, по умолчанию - 1 минута. Страницы перелистываются кнопками "Предыдущая F4", "Следущая F5" или контекстным меню панели состояния, где казывается число страниц в файле данных и номер текущей страницы.


Кадр

Временной лаг, по которому разбивается страница обработки, размер устанавливается пользователем в настройках, по умолчанию - 1 минута. Служит для анализа временного распределения хода рыбы по времени.


Неизменяемые параметры

На вкладке справочно указаны параметры обработки, которые носят аппаратный характер, установлены при работе комплекса на воде и не могут быть изменены пользователем:

- номер комплека:

- номер модуля "Slave", данные с которого обрабатываются в текущем сеансе;

- берег реки, на котором был установлен комплекс, этот параметр мспользуется при определении направления движения рыб в градациях вверх-вниз по течению;

- интегральный фактор направленности гидроакустической антенны, устанавливается производителем;

- длительность зондирующего акустического импульса, использовавщееся при работе комплекса;

- максимальная дистанция регистрации, использовавщееся при работе комплекса.


Параметры среды

Параметры окружающей среды

На вкладке регулируются значения:

- соленность воды, промилле;

- температура воды, град. С;

- коэффициент затухания звука в воде, дБ/м.

При изменении указанных параметров происходит перерасчет скорости звука в воде и шага выборки аналого-цифрового преобразования.

При изменении указанных параметров становится доступной кнопке "Встроенные значения", по её нажатию значения указанных параметров изменяются на встроенные.


Параметры системы

На вкладке регулируются значения:

- коэффициент сжатия - логорифматор усилителя, измеряется изготовителем, не рекомендуется к самостоятельному изменению пользователем;

- системный аттенюатор - коэффициент сквозного усиления, измеряется изготовителем, не рекомендуется к самостоятельному изменению пользователем;

- электро-акустическая постоянная - константа интегрирования, измеряется изготовителем, не рекомендуется к самостоятельному изменению пользователем;

- шум - уровень электрических шумов на АЦП, измеряется изготовителем, не рекомендуется к самостоятельному изменению пользователем.

При изменении указанных параметров становится доступной кнопке "Встроенные значения", по её нажатию значения указанных параметров изменяются на встроенные.


Параметры обработки

На вкладке регулируются значения:

- верхняя граница, м - в диапазоне от поверхности антенны до верхней границы обработка не производится. Отмечается прерывистой горизонтальной линией на панели эхограммы, изменяется пользователем в целочисленном значении;

- временной лаг - интервал времени разбияния текущей страницы обработки на кадры, изменяется пользователем в целочисленном значении;

- минимальная TS, дБ - минимальная сила цели одиночной рыбы, изменяется пользователем в виде десятичной дроби, всегда имеет отрицательное значение;

- максимальная TS, дБ - максимальная сила цели одиночной рыбы, изменяется пользователем в виде десятичной дроби, всегда имеет отрицательное значение;

- апертура, ед. - параметр низкочастотной цифровой фильтрации, изменяется пользователем в целочисленном значении;

- минимальная длина следа - следы одиночных рыб, число непрерывных регистраций которых превышает минимальную длину следа, участвуют в определении направления движения, изменяется пользователем в целочисленном значении;

- коэффициент корреляции - критерий значимости определения направления движения рыбы в градациях вверх-вниз по течению, изменяется пользователем в виде десятичной дроби;

- критерий одиночной цели - множитель для длительности импульса, образует дипазон поиска одиночной цели, изменяется пользователем в виде десятичной дроби;

- определение направления - вычислять или не вычислять (выводить или не выводить) результаты определения направления движения рыб.

При изменении указанных параметров становится доступной кнопке "Встроенные значения", по её нажатию значения указанных параметров изменяются на встроенные.


Слой обработки

Обработка ведется только в слое, ограниченном верхней и нижней границами, устанавливаемыми в панели дистанции. Все полученные результаты относятся исключительно к выбранному слою обработки. При нажатии кнопки "Результаты F6" ход обработки индицирется движением вертикальной прерывистой линии по панели эхограммы в слое обработки.


Осциллограф

На поле отображается эхограмма одной посылки модуля "Slave", в зависимости от положения курсора на панели эхограммы. По оси абцисс- амплитуда эхосигнала в дБ, по оси ординат - отсчеты АЦП.


Элементы пользовательского интерфейса

This help file was created with the free trial version of HelpScribble.


This help file was created with the free trial version of HelpScribble

HelpScribble - The Complete Help Authoring Tool

This help file was created with the free evaluation version of HelpScribble. This ad and the little footers below each topic will be automatically removed when the author recompiles this help file with the full version of HelpScribble. HelpScribble can be purchased securely online and is covered by a risk-free 90-day unconditional money-back guarantee.

About HelpScribble

HelpScribble is a full-featured, easy-to-use help authoring tool for creating help files from start to finish. You can create WinHelp (.hlp) files, HTML Help (.chm) files, a printed manual and online documentation (on a web site) all from the same HelpScribble project.

If you have previously used another help authoring tool, you can reuse your work by importing the HPJ+RTF files created with the other tool or by a decompiler.

You can use the help files you make with HelpScribble to provide context-sensitive help with your Window applications, no matter which development tool you use. You can also use HelpScribble to create stand-alone portable documents.

Write Perfect Help Files for Your Software

You need HelpScribble to create a top quality help file for your software. Windows users expect to receive detailed documentation at a quick press of the F1 button. You will sell more copies of your software if a thoughtful help file flattens the learning curve for prospects trying the evaluation version of your product.

No matter which development tool you are using, you can always use a help file created with HelpScribble to provide context-sensitive help for your application.

If you know how to use a word processor, you can build a help file with HelpScribble. Creating new topics and adding links to them cannot be easier. No experience required.

Read more...

Portable Documents with Hyperlinks

With HelpScribble you can easily create hyperlinked documents that can be read on any computer running Windows.

The WinHelp files that you create with HelpScribble are a collection of linked pages, just like a web site. But unlike a web site, you only need to distribute one file. This file can be read on any Windows computer. No other software is needed.

You need absolutely no programming experience to use HelpScribble. Many word processors and HTML editors are more complicated than HelpScribble.

Read more...

The Complete Help Authoring Tool

HelpScribble is a full-featured stand-alone help authoring tool. It is not an add-on for MS Word like so many other help writing products. You can create the entire help file right within HelpScribble.

With HelpScribble you can even provide your documentation in several forms, all from the same source. You can add context-sensitive help to your application, print a manual and provide online documentation on your web site.

WinHelp

WinHelp is the help file format supported by all versions of Windows. It is fast, compact and supported by Windows 3.x, NT 3.x, 95, 98, ME, NT4, 2000 and XP. All Windows users are familiar with it. With any Windows development tool you can use WinHelp files to add context-sensitive help to your applications.

With HelpScribble you have all the functionality you need to build a complete help file, including table of contents, index, browse sequences, etc. With HelpScribble's SHG (image map) editor, you can make your pictures (screen shots) say more than a thousand words.

Read more...

Printed Manual

Reading from paper is a lot easier than reading from a screen. A printed manual or, for downloadable software, a printable manual in PDF format, adds greatly to the value of your product.

You can use your HelpScribble project as the basis for your printed manual. You can export your help text to one large RTF or HTML file that you or your DTP professional can turn into a finished manual using a word processor or DTP program.

Read more...

HTML Help

With Windows 98, Microsoft introduced a new help file format called HTML Help. Using HelpScribble, you can build classic WinHelp .hlp files and new HTML Help .chm files from the same source. You decide whether you want maximum compatibility with older computers, or if you want to offer a state of the art help system.

Read more...

Web Help

If you want to provide online documentation, you can create one large HTML file or a collection of HTML files from your HelpScribble project and upload those to your web site. Your customers will have instant access to the latest documentation at any time.

Read more...

Cross-Platform Help

If you are developing platforms such as Linux, where there is no standard help format, you can provide your documentation as HTML files. The user can easily view those files in a browser. If you use Kylix, you can even easily integrate them into your application.

Read more...

Number 1 Help Tool for Delphi & C++Builder

You can use HelpScribble no matter which development tool you use. Even if you use no development tool at all. (Stand-alone help files can be very useful.) But if you are a Delphi or C++Builder developer, you will certainly appreciate the way HelpScribble integrates with your favorite development tool.

HelpScribble's HelpContext property editor takes most of the tedious job of assigning Topic IDs to HelpContext properties out of your hands. Adding context-sensitive help to your application could not be easier. Simply click on the corresponding controls and help topics to link them.

Delphi developers like HelpScribble so much that it won the Delphi Informant Readers Choice awards three years in a row. In 1999, 2000 and 2001, HelpScribble was chosing the Best Help Authoring Package, beating well-known tools such as RoboHelp and ForeHelp.

Read more...

Do Not Take My Word For It

I could rattle on all day about how great HelpScribble is. But do not take my word for it!

Find out what the people say about HelpScribble before you decide to buy.

Chris Kryza

"Just wanted to let you folks know that you have created a very, very, very nice product! The last time I had to generate a context sensitive help file I used Doc-To-Help and I remember it took me weeks to get it right. With HelpScribble I was able to put together a complete help system in under 2 days and I then created a web-help deployment of same in seconds. I used your demo version to create the entire project and then purchased your product online after I saw how good it all looked. Great stuff!"

Roj Ash

"I just felt I had to compliment you on this product. I have no experience of producing Help files, and having evaluated a number of products, I was beginning to believe that a mere programmer had no chance whatever!

"I am not only making good progress in producing the Help for our product (which is usually used by **very** inexperienced users), but I'm actually enjoying it!

"Thanks for a great product."

Try the Free Evaluation Version Today

HelpScribble is an excellent help authoring tool. But do not take my word for it! Take a look at the self-running online demos or download the free evaluation version and see for yourself.

Convinced? Buy HelpScribble now!