Назначение

Настоящая справочная система посвящена работе с гидроакустическим двухчастотным программно-техническим комплексом (системой) «NetCorIP» по количественной оценке водных биомасс гидроакустическим методом в реальном и отложенном времени.

This help file was created with the free trial version of HelpScribble.


Краткое описание

Основное назначение комплекса - количественная оценка проходящих рыб через сканируемое сечение реки с возможностью восстановления распределения силы цели и определения направления их движения в градациях вверх-вниз по течению.

Комплекс состоит из сети плавучих гидроакустических высокочастотных многолучевых станций связанных по радиоканалу пакетной передачи данных с береговой компьютеризированной контрольно-измерительной системой. Радиопередача ведется в нелицензируемом диапазоне радиочастот ISM 2.4 ГГц с использованием трансиверов NanoLoc (стандарт IEEE 802.15.4a). Акустическое зондирование может осуществляться в горизонтальной плоскости под любым заданным углом к поверхности воды, в вертикальном направлении в направлении дна или поверхности воды.

Основные характеристики комплекса «NetCorIP»:

- рабочая частота 455 КГц;

- электрическая мощность на антенне 40 - 80 Вт;

- частота следования посылок - до12 Гц;

- ширина характеристики направленности одного луча на уровне -6 дБ 10 градусов, ширина многолучевого сектора на одной станции до 80 градусов в плоскости веера лучей;

- в горизонтальном режиме обеспечивается регистрация рыб при глубине места до 1 метра;

- максимальная дальность регистрации в горизонтальном режиме одиночной рыбы с силой цели -50 дБ - 20 метров;

- минимальная дальность регистрации - 0,5 метра;

- дистанция устойчивой радиосвязи - до 200 м, дистанция предельной радиосвязи - до 600 м (в зависимости от уровня помех и используемых антенн);

- число плавучих гидроакустических высокочастотных многолучевых станций в сети - до 16;

- математическое обеспечение системы состоит из программы управления комплексом и сбора данных с сети плавучих гидроакустических станций в реальном времени и программы камеральной обработки данных в отложенном времени на компьютерах платформы х86 под управлением ОС "Windows".


Контакты

185034, гор. Петрозаводск, пер. 4-й Родниковый, д. 17

Директор - к.т.н. Дёгтев Андрей Игоревич

+7 921 4565745

rickoshet_PHA@mail.ru

© ® ООО "ПромГидроакустика", 2005 - 2018


Плавучее оборудование

Сеть плавучих автономных гидроакустических станций, на которых установлены:

- модулямь «Slave»;

- поворотно-выдвижное устройство с ненаправленной радионтенной и гидроакустической антенной;

- аккумулятор.

Стеклопластиковая полая плавучая платформа, грузоподъемностью 30 кг, имеет колодец для пропуска ПВУ, самоотливной кокпит для аккумулятора, лючок для доступа внутрь, сапун и устройства для крепления якорных концов. На ПВУ штатно крепятся гидроакустическая антенна и модуль «Slave».

Берег установки станции считается левым, если гидроакустическая антенна смотрит от левого берега реки, Берег установки станции считается правым, если гидроакустическая антенна смотрит от правого берега реки


Береговое оборудование

Береговое оборудование состоит из:

- модуля "Master" с направленной радиоантенной;

- компьютера-ноутбука;

- аккумулятора;

- сетевого кабеля;

- внешнего устройства памяти.


Сборка и включение

1. Соберите модуль "Slave" на плавучей платформе и подключите его к аккумулятору, штыревой радиоантенне. Установите платформу на акватории в прямой видимости от модуля "Master", направьте гидроакустическую антенну в нужном направлении.

2. Подключите к модулю "Master" внешнее устройство памяти.

3. Подключите модуль "Master" к аккумулятору и направленной радиоантенне.

4. Произведите установку модуля "Master"

Управление комплексом осуществляется через пользовательский интерфейс в зависимости от выбранного режима.

Запустите программу "NetCor. Экспедиция".


Состав ПО

Программное обеспечение реального времени состоит из исполняемого модуля Expedition.exe, библиотеки PHA64.dll, файла встроенной помощи Expedition.chm, программы управления работой модуля "Master", поставляемой на карте SD HC 10 4 ГБ.


Установка ПО

Программное обеспечение поставляется в виде установочной программы Setup.exe на диске CD. Программа установки создает каталог NetCorIP на диске С, в каталог NetCorIP копирутся файлы Expedition.exe и PHA64.dll, и создаются каталоги EchoData и Help. В каталог Help копируются файлы встроенной справочной системы, в каталог EchoData пользователь переносит файлы данных для обработки. В каталог CardImage копируются файл образа карты памяти модуля "Master" и установочная программы физического копирования этого образа на новую карту памяти.

На CD диске находится также каталог NetCorIP со всеми указанными выше файлами, можно просто скопировать этот каталог на диск C.


Удаление ПО

Удаление программного обеспечения осуществляется средствами ОС Windows или программой uninstall.exe..


Файл данных

В файл данных системы «NetCorIP» записывается цифровое представление огибающей эхосигнала и номера работающих модулей. Имя файла данных - "ddmmyy_hhmm.rnd", где ddmmyy - текущая системная дата открытия файла, hhmm - текущее системное время. В файл данных записываются данные со всех модулей "Slave", работавших в момент записи.

Файл данных не может быть изменен пользователем с использованием средств настоящей программы.

Структура файла:

struct

{

unsigned char //физический номер модуля "Slave" (адрес)

unsigned char //не используется

unsigned char //частота выборки АЦП (базовый диапазон)

unsigned char //длительность имульса

unsigned char //мощность генератора

unsigned char * //порядок работы элементов антенны

unsigned char //не используется

unsigned char //берег

}

struct

{

unsigned char //логический номер модуля "Slave"

unsigned char //физический номер модуля "Slave" (адрес)

unsigned char //год

unsigned char //месяц

unsigned char //число

unsigned char //час

unsigned char //минута

unsigned char //секунда

unsigned char * //целочисленный массив отсчетов АЦП

}

Файл данных записывается модулем "Master" на внешнее устройство памяти (USB накопитель), в его корне обязательно (!!!) должна быть сформированная папка "EchoData"!


Файл конфигурации

Имя и путь двоичного файла - C:\NetCorIP\ExpConfig.cfg.

В файле сохраняются структуры параметров работы программы:

struct

{

unsigned char //серийный номер комплекса

unsigned char //число модулей "Slave" в системе

};

struct

{

int //солёность

int //температура

double //коэффициент затухания

};

struct

{

unsigned char //физический номер (адрес) модуля "Slave"

unsigned char //не используется

unsigned char //частота выборки АЦП

unsigned char //длительность импульса

unsigned char //мощность генератор

unsigned char * //последовательность работы элементов гидроакустической антенны

unsigned char //не используется

unsigned char //берег

}*;


Пользовательский интерфейс

Пользовательский интерфейс программы состоит из:

панели главного меню (верхняя панель);

панели состояния главного окна (нижняя панель);

окон модулей (по числу работающих модулей "Slave" устанавливаемого пользователем при конфигурации системы) в центральной части.


Панель главного меню

Панель состоит из следующих кнопок:

- "Помощь F1";

- "Авторежим F3";

- "Старт F4";

- "Эхограмма F6";

- "Фильтр F8";

- "Выход F10";

- "О программе F11".


Панель состояния главного окна

В поля (слева-направо) панели выводятся следующие данные:

- источник эхосигнала: система - в реальном времени, файл - в отложенном времени;

- IP адрес модуля "Master" в реальном времени, имя файла данных в отложенном времени;

- модули "Slave" работающие в системе, логические и физические номера.


Окно модуля "Slave"

Окно состоит из следующих элементов:

- панели меню модуля "Slave";

- панели цветности;

- панели эхограммы;

- панели дистанции;

- панели состояния модуля "Slave".


Эхограмма

Поле отображает подводную обстановку в виде эхограммы


Панель меню модуля "Slave"

Панель состоит из кнопок:

- "Настройка F2";

- "Осциллограф F5";

- "Сектор F7";

- "Каналы F9".


Панель цветности

Поле отображает условное соответствие цвета и интенсивности эхосигнала, является элементом управления:

- левый "клик" мыши изменяет порог регистрации на значение у курсора, перестраивается панель цветности, панель эхограммы;

- если сделать левый "клик" мышью в районе значения -18 - значение порога регистрации вернется к рекомендованному значению;

- правый "клик" мыши вызывает простое контекстное меню для изменения цветного изображения эхограммы на черно-белое и обратно и изменения фона эхограммы с белого на черный и обратно.


Панель дистанции

Поле представляет собой шкалу дистанции в метрах.


Панель состояния модуля "Slave"

В поля (слева-направо) панели выводятся следующие данные:

- напряжение питания (аккумулятора);

- предупреждение, если напряжение питания (аккумулятора) упадёт ниже 11 вольт;

- последовательность работы элементов гидроакустической антенны;

- два служебных поля с информацией об условиях прохождения радиосигнала;

- счётчик отображённых посылок модуля "Slave" на эхограмме.


Запуск программы

Запустите программу Expedition.exe средствами ОС "Windows", появится окно приглашения:

Отметьте слово "Система", чтобы перейти в режим реального времени, отметьте слова "Файл данных", чтобы перейти в режим отложенного времени.

При выборе режима реального времени, система попытается определить модуль "Master", если это не удастся, появится сообщение:

.

Попробуйте повторить процедуру, если не удастся - вернитесь к процедуре установки модуля "Master".

В режиме реального времени появится окно "Проверки статуса системы" с движущейся полосой

По окончании проверки статуса появится сообщение о работе системы в ручном или автоматическом режиме. В первом включении - всегда ручной.

Нажмите кнопку "OK", откроется окно "Конфигурации системы"

Если это окно просто закрыть, система перейдет в режим просмотра файла.

В окне "Конфигурации системы" пользователь выбирает нужное число модулей "Slave", физические номера используемых модулей. и назначает их параметры.

Нажав кнопку "Сохранённые параметры", пользователь войдет в систему с набором параметров предыдущего сеанса работы.

Нажатием кнопки «Загрузить параметры в выбранные модули «Slave» пользователь инициализирует систему и появляется окно регистрации и параметризации модулей "Slave".

Система предпринимает ряд последовательных попыток зарегистрировать и загрузить параметры в модули «Slave», успех или неуспех которых отмечается изменением цвета и текста в соответствующих полях. Поля модулей, для которых не удались либо регистрация, либо параметризация, остаются отмеченными красным цветом, что означает неисправность конкретного модуля "Slave". Если все модули "Slave", указанные пользователем в окне конфигурации, успешно зарегистрировались и параметризировались, окно закроется, и система перейдет в режим реального времени. Если хоть один модуль "Slave" не пройдет регистрацию или параметризацию, окно закроется, система перейдет в режим отложенного времени.

Пример успешных регистрации и параметризации системы из одного модуля:

Пример неуспешной регистрации системы из одного модуля:

Это окно закроется, и откроется окно пользовательского интерфейса для соответствующего режима работы системы.


Сбор данных

1. После запуска программы в режиме реального времени убедитесь, что на пользовательском интерфейсе присутствуют все окна модулей "Slave".

2. При необходимости убедитесь, что параметры работы модулей соответствуют установленным при запуске программы.

3. Нажмите кнопку "Старт F4" - начнется движение эхограммы в окнах модулей.

4. Оцените подводную обстановку на эхограммах, при необходимости переустановите плавучее оборудование и измените параметры работы модулей "Slave" в процедуре запуска программы.

5. Убедитесь, что к модулю "Master" подключен внешний USB накопитель, и, что на нем в корне есть каталог EchoData.

6. Нажмите кнопку "Авторежим F3" - система перейдет в автоматический режим, начнется запись файла данных на внешний накопитель модуля "Master". Кнопка "Авторежим F3" изменит название, кнопка "Старт F4" станет недоступной, на панели состояния появится извещение, что система находится в авторежиме. Если системе не удастся открыть файл данных на внешнем носителе модуля "Master" появится сообщение:

Нажмите OK, выйдите из программы, проверьте (замените) внешний накопитель и повторите всю описанную выше процедуру.

7. Выйдите из программы, отключите сетевой кабель, уберите компьютер - система автономно собирает данные.


Съём данных

1. Подключите ноутбук к модулю "Master" сетевым кабелем.

2. Запустите программу в режиме реального времени.

3. Если система была оставлена в автономном режиме, появится сообщение:

4. Если нажать кнопку OK система продолжит работу в автономном режиме.

5. Если нажать кнопку "Отмена" система остановит работу, выйдите из программы и замените внешний накопитель.

6. Для продолжения работы вновь запустите программу в режиме реального времени и продолжите сбор данных.

Никогда не меняйте устройство внешней памяти в автономном режиме.

Если система не выходит из автономного режима - закройте программу, отключите питание модуля "Master", через 1 - 2 минуты включите снова, дайте загрузиться внутренней программе модуля "Master" (1 - 2 минуты), вновь загрузите программу "NetCorIP. Экспедиция" и повторите все снова.


Просмотр файла данных

При просмотре файлов данных в отложенном времени компьютер может быть как подключенным, так и отключенным от системы "NetCorIP".

Запустите программу и в окне приглашения выберите источник сигнала - файл.

Программа войдет в режим отложенного времени с тем же пользовательским интерфейсом, что и в случае реального времени.

Нажмите кнопку "Файл F3" и выберите файл данных.

Нажмите кнопку "Старт F4", в окнах модулей "Slave" начнется показ эхограммы с подводной обстановкой.


Обслуживание

Число необходимых аккумуляторов = числу используемых модулей "Slave" + один на модуль "Master" + один оборотный.

Число внешних устройств памяти - два.

Ресурс работы одного аккумулятора (40 ампер-часов) на модуле "Slave" - не менее трех суток, на модуле "Master" - не менее трех суток.

Цикл обслуживания:

1. После первых суток работы системы меняете аккумулятор на любом устройстве и уносите его на зарядку, на следующий день меняете на другом потребителе и так, в цикле - весь период наблюдения.

2. Рекомендуется каждые сутки менять внешний накопитель и относить данные на хранение или обработку, при этом его освобождая.

Замена карты памяти в модуле "Master"

Отключите модуль "Master" от аккумулятора, примите меры против накопления на руках пользователя статического электричества.

В комлекте идет запасная карта памяти с программным обеспечением, являющаяся системным диском мини-ЭВМ модуля "Master".

Отверните шесть саморезных винтов на верхней крышке модуля "Master", откройте крышку, не отключая проводов, замените карту памяти.

Что бы изготовить новую карту памяти запустите программу HDDRawCopy1.10Setup из каталога CardImage, она установит программу физического копирования, запустите её - там понятный интерфейс. Источником копирования будет файл cardNetCor.imgc в этом каталоге, цель копирования - новая карта памяти.

Замена сетевого кабеля

Отключите модуль "Master" от аккумулятора, примите меры против накопления на руках пользователя статического электричества.

Отсоедините сетевой кабель от компьютера.

Отверните шесть саморезных винтов на верхней крышке модуля "Master", откройте крышку.

Обрежьте кабель с любой стороны модуля, ослабьте гайку сальника и вытащите кабель.

Введите новый кабель, на его концах разделайте стандартный разъем J45, вставьте кабель в тот же разъем внутри модуля "Master".

Замена предохранителя в модулях "Slave" и "Master"

Отверните шесть саморезных винтов на верхней крышке модуля, откройте крышку.

Замените плавкий предохраниетель, номинал - 1 - 2 ампера (не более).

Не закрывая крышки проверьте работу модуля, если предохранитель опять сгорел - неисправность неустранима пользователем, обратитесь к изготовителю.

Устанавливая крышку модуля "Slave" используйте силиконовый герметик.


Введение

This help file was created with the free trial version of HelpScribble.


Реальное время

Под реальным временем здесь подразумевается время работы системы при проведении гидроакустической съемки непосредственно на водоеме.


Отложенное время

Под отложенным временем здесь подразумевается время работы системы при просмотре и обработке собранного материала после проведения съемки.


Аппаратная часть

This help file was created with the free trial version of HelpScribble.


Модуль "Slave"

Модуль «Slave» состоит из программно-управляемого генератора-приемника, АЦП, радио приемного и передающего устройства стандарта NanoLoc, ненаправленной радиоантенны. Осуществляет гидроакустическое сканирование подводной обстановки с параметрами задаваемыми модулем «Master» и передачу данных в компьютер по радиоканалу через модуль «Master». На корпусе гравировкой и наклейкой указан физический номер модуля. Модуль подключен к ненаправленной (штыревой) радиоантенне.


Гидроакустическая антенна

Серийная многолучевая высокочастотная (455 КГц) гидроакустическая антенна SHS 7W.

Физический номер модуля, с которым работает эта антенна. выгравирован на корпусе антенны и дублирован наклейкой.


Физический номер

Физический номер модуля «Slave» записан в ПЗУ модуля, состоит из двух байт: старший - серийный номер комплекса, младший - адрес модуля в сети, в пользовательском интерфейсе программы показывается только младший байт, как физический номер конкретного модуля «Slave». Не может быть изменен пользователем! Физический номер выгравирован на корпусе и дублирован наклейкой, то же сделано на гидроакустической антенне соответствующего модуля.

Каждый модуль «Slave» имеет два номера: физический (адрес в сети) и логический.


Логический номер

Логический номер определяет последовательность работы модулей в сети и является, по сути, именем, назначаемым пользователем, каждому модулю «Slave» в конкретной реализации сети. Логический номер определяется пользователем.


Аккумулятор

Используется любой (кислотный или щелочной) необслуживаемый аккумулятор с рабочим напряжением 12 вольт постоянного тока, рекомендуемая емкость - не менее 40 ампер-часов. Порядок работы непосредственно с аккумулятором и его основные тактико-технические данные приведены в инструкции производителя к нему и здесь не рассматриваются.


Компьютер-ноутбук

Используется ноутбук платформы х86 под управлением ОС "Windows " семейства NT.


Модуль "Master"

Модуль «Master» - внешнее устройство (интерфейс системы), осуществляющее управление сетью модулей «Slave» и прием данных по радиоканалу, подключение к компьютеру по интерфейсу Fast Ethernet, питание 12 вольт постоянного тока. Фотография модуля «Master», подключенного к направленной радиоантенне.


Сетевой кабель

This help file was created with the free trial version of HelpScribble.


Внешнее устройство памяти

Внешний USB накопитель емкостью 5 - 8 Гб. В процессе работы на нем записывается файл данных, периодически пользователь меняет устройство на новое, прежние данные отдаются на обработку.

Устройство должно сформатировано в системе FAT.

В корне должен быть каталог "EchoData", убедитесь в этом или сделайте это вручную.

Расход памяти - до 1.5 Гб в сутки.


Программное обеспечение

This help file was created with the free trial version of HelpScribble.


Установка модуля "Master"

Подключите модуль "Master" к питанию 12 вольт постоянного тока и подключите его к компьютеру сетевым кабелем.

Настоятельно рекомендуется отключение всех беспроводных сетевых подключений и устройств Bluetooth и Wi-Fi !!!

Отключите антивирусное программное программное обеспечение на вашем компьтере или настройте его таким образом, чтобы оно не блокировало сетевое соединение компьютера с модулем "Master".

Отключите брандмауэр Windows (или другой используемый) на вашем компьтере или настройте его таким образом, чтобы оно не блокировало сетевое соединение компьютера с модулем "Master".

Откройте «Центр управления сетями и общим доступом». Откройте "неопознанную" сеть.

Откройте свойства и далее компоненту TCP/IPv4

Введите IP-адрес 192.168.2.10, маску подсети 255.255.255.0.

Последовательно закройте все открытые окна нажатием кнопки «ОК» или «Закрыть».


Работа с комплексом

This help file was created with the free trial version of HelpScribble.


Ручной режим

Компьютер подключен, всё управление системой и сбор данных осуществляется компьютером по сетевому кабелю. Файл данных не записывается. Режим используется для запуска, настройки и контроля работы системы.


Автоматический режим

Автономный режим

В автоматическом режиме всё управление системой и сбор данных осуществляется модулем "Master", компьютер отключен, файл данных записывается на внешний накопитель. Параметры работы системы устанавливаются пользователем в ручном режиме.


Параметры

Параметры модуля.

"Базовый диапазон" (макс. дистанция регистрации), встроенное значение 10 метров.

"Длительность посылки", длительность гидроакустического зондирующего модуля, встроенное значение 0,2 мс.

"Мощность" генератора, встроенное значение min.

"Берег", направление сканирования, встроенное значение - левый.

Включенные элементы гидроакустической антенны, встроенное значение - с первого по шестой включительно.

Физический номер модуля "Slave", записан в ПЗУ модуля, не может быть изменен пользователем.

Параметры среды.

Соленность воды, встроенное значение 0, макс. 35 промилле.

Температура воды, встроенное значение 0, макс. 30 град С.

Коэффициент затухания звука в воде, встроенное значение 0,0546 дБ/м.

Константы.

Шум, встроенное значение 100.

Системный аттенюатор, индивидуальное встроенное значение для каждого модуля "Slave".

Коэффициент сжатия, индивидуальное встроенное значение для каждого модуля "Slave".

Параметры изображения.

Порог регистрации, встроенное значение -50 дБ, мин. -50 дБ, значение более -42 дБ не рекомендуется.

Цветность, встроенное значение цветное, возможно использования черно-белого, на результаты не влияет.

Фон эхограммы, встроенное значение дневное (белое), возможно использования черного (ночного), на результаты не влияет.


Помощь F1

Открывает встроенную справочную систему.


Авторежим F3

Недоступна до нажатия кнопки "Старт F4" панели главного меню.

По нажатию происходит переключение из ручного в автоматический режим.


Файл F3

Открывает файл данных для его просмотра в режиме отложенного времени.

По умолчанию файлы ищутся в каталоге C:\NetCorIP\EchoData, но могут открываться и из любого другого каталога или носителя.


Старт F4

Запускает (останавливает) работу системы, недоступна после перевода системы в автоматический режим.


Суммарная эхограммма F6

Открывает (закрывает) окно, в которое выводятся эхограммы со всех работающих модулей "Slave" в системе, если их число более одного.

Кнопка недоступна, если используется только один модуль "Slave".


Фильтр F8

Включает (выключает) цифровую фильтрацию эхограммы (фильтр низких частот).

Включенный фильтр не искажает данные, записываемые в файл данных.


Выход F10

Закрывает программу.

Корректно закрываются файлы данных и результатов, если открыты.

Если пользователем были изменены параметры, появляется приглашение об их сохранении в файле конфигурации:


О программе F11

Содержит информацию о программе и разработчике.


Настройка F2

Вызывает окно настройки параметров работы модуля "Slave".

Окно настроек состоит из трёх вкладок:

- "Параметры модуля";

- "Параметры среды";

- "Константы".

Если окно настроек вызвано из окна модуля "Slave", настройка параметров недоступна, настройка параметров работы модулей "Slave" производится при запуске программы в окне конфигурации.

Если окно настроек вызвано в режиме просмотра файла данных, настройка параметров недоступна


Осциллограф F5

Вызывает (закрывает) окно осциллографа.


Сектор F7

Вызывает (закрывает) секторного представления подводной обстановки.


Каналы F9

Вызывает (закрывает) окна эхограмм, в каждом котором отражается подводная обстановка по элементам гидроакустической антенны.


Параметры модуля

Вкладка состоит из:

- выпадающего списка "Базовый диапазон" (макс. дистанция регистрации), доступные значения: 10 и 20 метров;

- выпадающего списка "Длительность посылки", доступные значения: 0.2, 0.4, 0.6 и 0.8 мс;

- выпадающего списка "Мощность" генератора, доступные значения: min и max;

- выпадающего списка "Берег", доступные значения: левый и правый;

- списка включенных элементов гидроакустической антенны;

- панели состояния с указаниями логического и физического номера модуля "Slave".


Параметры среды

На вкладке регулируются значения:

- соленность воды, промилле;

- температура воды, град. С;

- коэффициент затухания звука в воде, дБ/м.

При изменении указанных параметров происходит перерасчет скорости звука в воде и шага выборки аналого-цифрового преобразования.


Константы

На вкладке регулируются значения:

- шум - уровень электрических шумов на АЦП, измеряется изготовителем, не рекомендуется к самостоятельному изменению пользователем;

- системный аттенюатор - коэффициент сквозного усиления, измеряется изготовителем, не рекомендуется к самостоятельному изменению пользователем;

- коэффициент сжатия - логорифматор усилителя, измеряется изготовителем, не рекомендуется к самостоятельному изменению пользователем.


Элементы пользовательского интерфейса

This help file was created with the free trial version of HelpScribble.


Карта памяти модуля "Slave"

Карта содержит программу управления работой модуля "Master".

В комплекте системы дается запасная карта, пользователь может самостоятельно изготовить запасную карту.


This help file was created with the free trial version of HelpScribble

HelpScribble - The Complete Help Authoring Tool

This help file was created with the free evaluation version of HelpScribble. This ad and the little footers below each topic will be automatically removed when the author recompiles this help file with the full version of HelpScribble. HelpScribble can be purchased securely online and is covered by a risk-free 90-day unconditional money-back guarantee.

About HelpScribble

HelpScribble is a full-featured, easy-to-use help authoring tool for creating help files from start to finish. You can create WinHelp (.hlp) files, HTML Help (.chm) files, a printed manual and online documentation (on a web site) all from the same HelpScribble project.

If you have previously used another help authoring tool, you can reuse your work by importing the HPJ+RTF files created with the other tool or by a decompiler.

You can use the help files you make with HelpScribble to provide context-sensitive help with your Window applications, no matter which development tool you use. You can also use HelpScribble to create stand-alone portable documents.

Write Perfect Help Files for Your Software

You need HelpScribble to create a top quality help file for your software. Windows users expect to receive detailed documentation at a quick press of the F1 button. You will sell more copies of your software if a thoughtful help file flattens the learning curve for prospects trying the evaluation version of your product.

No matter which development tool you are using, you can always use a help file created with HelpScribble to provide context-sensitive help for your application.

If you know how to use a word processor, you can build a help file with HelpScribble. Creating new topics and adding links to them cannot be easier. No experience required.

Read more...

Portable Documents with Hyperlinks

With HelpScribble you can easily create hyperlinked documents that can be read on any computer running Windows.

The WinHelp files that you create with HelpScribble are a collection of linked pages, just like a web site. But unlike a web site, you only need to distribute one file. This file can be read on any Windows computer. No other software is needed.

You need absolutely no programming experience to use HelpScribble. Many word processors and HTML editors are more complicated than HelpScribble.

Read more...

The Complete Help Authoring Tool

HelpScribble is a full-featured stand-alone help authoring tool. It is not an add-on for MS Word like so many other help writing products. You can create the entire help file right within HelpScribble.

With HelpScribble you can even provide your documentation in several forms, all from the same source. You can add context-sensitive help to your application, print a manual and provide online documentation on your web site.

WinHelp

WinHelp is the help file format supported by all versions of Windows. It is fast, compact and supported by Windows 3.x, NT 3.x, 95, 98, ME, NT4, 2000 and XP. All Windows users are familiar with it. With any Windows development tool you can use WinHelp files to add context-sensitive help to your applications.

With HelpScribble you have all the functionality you need to build a complete help file, including table of contents, index, browse sequences, etc. With HelpScribble's SHG (image map) editor, you can make your pictures (screen shots) say more than a thousand words.

Read more...

Printed Manual

Reading from paper is a lot easier than reading from a screen. A printed manual or, for downloadable software, a printable manual in PDF format, adds greatly to the value of your product.

You can use your HelpScribble project as the basis for your printed manual. You can export your help text to one large RTF or HTML file that you or your DTP professional can turn into a finished manual using a word processor or DTP program.

Read more...

HTML Help

With Windows 98, Microsoft introduced a new help file format called HTML Help. Using HelpScribble, you can build classic WinHelp .hlp files and new HTML Help .chm files from the same source. You decide whether you want maximum compatibility with older computers, or if you want to offer a state of the art help system.

Read more...

Web Help

If you want to provide online documentation, you can create one large HTML file or a collection of HTML files from your HelpScribble project and upload those to your web site. Your customers will have instant access to the latest documentation at any time.

Read more...

Cross-Platform Help

If you are developing platforms such as Linux, where there is no standard help format, you can provide your documentation as HTML files. The user can easily view those files in a browser. If you use Kylix, you can even easily integrate them into your application.

Read more...

Number 1 Help Tool for Delphi & C++Builder

You can use HelpScribble no matter which development tool you use. Even if you use no development tool at all. (Stand-alone help files can be very useful.) But if you are a Delphi or C++Builder developer, you will certainly appreciate the way HelpScribble integrates with your favorite development tool.

HelpScribble's HelpContext property editor takes most of the tedious job of assigning Topic IDs to HelpContext properties out of your hands. Adding context-sensitive help to your application could not be easier. Simply click on the corresponding controls and help topics to link them.

Delphi developers like HelpScribble so much that it won the Delphi Informant Readers Choice awards three years in a row. In 1999, 2000 and 2001, HelpScribble was chosing the Best Help Authoring Package, beating well-known tools such as RoboHelp and ForeHelp.

Read more...

Do Not Take My Word For It

I could rattle on all day about how great HelpScribble is. But do not take my word for it!

Find out what the people say about HelpScribble before you decide to buy.

Chris Kryza

"Just wanted to let you folks know that you have created a very, very, very nice product! The last time I had to generate a context sensitive help file I used Doc-To-Help and I remember it took me weeks to get it right. With HelpScribble I was able to put together a complete help system in under 2 days and I then created a web-help deployment of same in seconds. I used your demo version to create the entire project and then purchased your product online after I saw how good it all looked. Great stuff!"

Roj Ash

"I just felt I had to compliment you on this product. I have no experience of producing Help files, and having evaluated a number of products, I was beginning to believe that a mere programmer had no chance whatever!

"I am not only making good progress in producing the Help for our product (which is usually used by **very** inexperienced users), but I'm actually enjoying it!

"Thanks for a great product."

Try the Free Evaluation Version Today

HelpScribble is an excellent help authoring tool. But do not take my word for it! Take a look at the self-running online demos or download the free evaluation version and see for yourself.

Convinced? Buy HelpScribble now!